I have a s10 that the fuel pump no pump. Placed in a brand-new fuel pump and also it pump for a couple of secs and also quit. Every wires test an excellent and no shorts. Negative relay?


You are watching: 97 s10 fuel pump relay location

*

the does sounds prefer the relay is poor but to it is in sure below is a guide to help you action by step with indict in the diagrams listed below to show you exactly how on your car.https://www.chathamtownfc.net/articles/how-to-check-an-electrical-relay-and-wiring-control-circuitCheck out the diagrams (Below). Permit us understand what happens and please upload images or videos the the problem.
*

*

*

*

correctly I placed in a jumper at the relay and also the fuel pump will certainly run. I placed in a new relay and it fixed it say thanks to you for the guide.
Fuel pump no working. Have actually replaced it v a new one, no luck. No voltage in ~ grey cable to pump.Have swapped out the relay, no luckHave inspect the fuse alongside the relay, okay. There is voltage in ~ the fuse (test light)I have actually read there is a place where you deserve to test the circuit by giving a 12 volts jumper which have to then cause the pump to operation (or tell you over there is a difficulty like a broken line - grey wire). Yet I don't know where this is.Assuming the heat is it s okay to the pump, what to be I missing that is keeping the pump from getting power?The engine has spark and so on. Does not run. No password comes increase via the scanner.
an excellent morning, fastened a wire diagram for you to view. You re welcome verify powers to the relay v the crucial on because that me and let me understand the voltage.The primer wire you room talking about was for the larger models and is no in her truck.Roy
for this reason voltage in ~ the ECM B fuse v the fuse removed and also the relay in place?Or fuse in place and also relay removed?(Or both, due to the fact that I'll be appropriate there?)Thanks!
Fuse in place. Check for strength to pin 30. The other, 86, need to only have voltage through the crucial on for 2 secs as it comes from the pcm. It will save voltage while cranking.If you jump 30 and also 87, the pump need to run.Roy
This makes sense.My only confusion is top top the to know of the 4 pins. If i unplug the relay, I think the pins are in a rectangle-shaped set-up conversely, the drawing you noted has castle in a linear collection up.I carry out recall recognize voltage at one of them with the an essential on.So looking down at where the relay to be removed, from the driver's side fender, who is who?Thank you! john
Look in ~ the bottom of the relay. They need to be significant 30, 87, 86, 85.You run the 12-volt power or pen 30 come 87 i m sorry is the gray wire to the pump.Roy
Okay! We got it running. The grounds because that the computer and other electrical's were rusted and also not working. 218,000 mile in brand-new England go that, sadly.Thanks for the an excellent information. We have actually printed it all up and also tucked that away for future reference. Man
Fuel pump just stopped take it it out of the tank inspect the connections an no power, checked the relay & fuses all good, have power at the relay, tryed one more relay an quiet no power at the pump, what am i missing?
The computer system energizes the fuel pump relay and also relay will certainly de-energized in 2secs. In ~ which time as soon as the auto fires increase the oil pressure sending unit strength the pump-All you obtained is 2secs to check for power at the connector. Also see below

*


Engine turns over however will not start. Did no hear fuel pump running once ignition is only in on position. Checked fuses and also fuel pump relay. Deserve to hear the fuel pump relay click when the ECM B fuse is inserted with the ignition in the top top position. Changed fuel pump. Still behaves the exact same way.


See more: How Many Calories In A 16 Oz Beer, 16 Oz: Calories, Nutrition Analysis & More

I totally forgot to walk in here and update this write-up after I fixed the problem. Ns was going v some old e-mail and also saw where I had signed up for this forum and realized the I never updated it. So right here goes. End a year later. However, the difficulty was solved in a few days! I had actually taken the bed off of the van to do it easier to readjust the fuel pump. After instead of the fuel pump ns tried to start the truck. No luck, very same as before. Acquiring to the point of providing up. Ns went ahead and put the truck bed back on again. I just happened come be sitting in the drivers seat simply wondering what in the people could it is in wrong as soon as I reached down and also for some reason simply turned the key. It started! The just thing ns can figure is the there was a ground wire that needed to be associated that wasn"t when the bed had actually been off. However anyway, the new fuel pump did resolve the problem and the truck has actually run great this past year.